CyanogenMod
  1. CyanogenMod
  2. CYAN-283

Short press of Menu, Home, and Back keys register as long press

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Instructions:
      I have read these instructions

      Description

      Same issue as mentioned in CYAN-152, against 10.1-M1, with logs. In the attached log files, the -pre-reboot suffixed files are with the issue occurring, while -post-reboot is after rebooting the phone which resolved the issue, for comparison.

      There's no clear pattern as to what causes this. Seems to start happening some time when the phone is asleep, though I feel I have seen it start while the phone is awake. Restarting ADWLauncher doesn't help, and the issue happens on any screen, including the lock screen. I have menu unlock and long-press Home for torch enabled on the lock screen.

        Activity

        cordell abney added a comment -

        Unfortunately I had to reboot at hour 24 1/2. However I still had short/long press working as intended before the reboot. I have also passed the builds off to a few of my testers (SlimROM) and have had nothing but positive results with this removed on both d2vzw and d2spr.

        blk_jack added a comment -

        I got to hour 27 without any reduction whatsoever. Looks like the workaround works!

        Shareef Ali added a comment -

        fix is committed.

        Chris Leon added a comment -

        I also get this problem (usually after a night of charging). I disable my alarm and try to go home. It goes bonkers repeating long press commands. Reboot fixes it until the next day


          People

          • Assignee:
            Steve Kondik
            Reporter:
            Cory Johns
          • Votes:
            42 Vote for this issue
            Watchers:
            52 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: