CyanogenMod
  1. CyanogenMod
  2. CYAN-4047

Android systemui crashes -- much less frequent after 20140517 nightly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 11.0m6
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None

      Description

      My Samsung i9300 device have multiples system crashes (with browsers, spotify application, facebook application, etc ...) since i have installed cm-11-20140504-SNAPSHOT-M6-i9300 version. However, this cm11-20140405-nightly version haven't this bug. Please analyse this problem. Thank you. Best regards

      1. 2014-05-10-16-33-27.txt
        952 kB
        Kamil Markowicz
      2. 2014-05-12-14-23-58.txt
        32 kB
        Stefan
      3. 2014-05-12-14-39-22.txt
        50 kB
        Stefan
      4. 2014-05-12-15-07-22.txt
        34 kB
        Stefan
      5. CHANGES.txt
        10 kB
        Sean Wood
      6. cm11-m6log.txt
        2.04 MB
        Gilles Maury
      7. log.txt
        297 kB
        Thomas Förster
      8. logcat_01.log
        536 kB
        guijarrelson
      9. logcat_02.log
        349 kB
        guijarrelson
      10. logcat_03.log
        448 kB
        Kamil Markowicz

        Issue Links

          Activity

          Tim Nicol added a comment -

          Any progress on finding the leak(s)?

          Ayman AlAnsari added a comment -

          After 20140517 nightly, the issue was reoccurring only once after each reboot, and rarely twice with multiple hours between them.
          I've updated to 20140524 about an hour ago, and the issue hasn't reproduced after 2 reboots so far. I'll report back in a couple of days.
          I don't recharge my phone much, I replace my battery with a backup battery instead, so I reboot my phone 1-2 times a day at least. If the issue is still recurring, I'll definitely experience it.

          Ayman AlAnsari added a comment -

          The issue was not resolved with the theme updates in 20140524. I'm on 20140527 I the phone was caught in systemui crash loop. Will update only when there is a significant change, this thread is way too long already.

          Clark Scheff added a comment -

          For the love of god, will someone please re-title this bug to reflect the exact crash happening. It's still too vague and can cover ANY SystemUI crash. Is the crash due to a specific NPE, is it caused from a java layer memory leak, is it crashing due to a missing resource? Let's get this updated so that it reflects the actual bug we want to track down and fix.

          Clark Scheff added a comment -

          When this bug was first reported, the problem was that SystemUI would become unresponsive and eventually crash or cause a hot reboot. We addressed this problem with a patch to external/skia. We've since received reports of other SystemUI crashes that have nothing to do with the problem we initially tracked down and fixed. I am labeling this as fixed based on our prior work on this bug. 11.0m7 should include this fix, and current nightlies are already patched as of 05/17/2014.

          If other SystemUI crashes occur, then new bugs should be opened with details of the crash including logs showing what caused the crash (if possible).


            People

            • Assignee:
              Clark Scheff
              Reporter:
              Gilles Maury
            • Votes:
              89 Vote for this issue
              Watchers:
              75 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: