Uploaded image for project: 'CyanogenMod'
  1. CyanogenMod
  2. CYAN-79

Changing exposure has no effect when taking photos

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 11.0m8
    • Fix Version/s: None
    • Component/s: Camera
    • Labels:
      None
    • Instructions:
      I have not read these instructions
    • Model:
      d2att
    • CM Download source:
    • Radio/baseband:
      I747UCLEM
    • Kernel version:
      stock

      Description

      What steps will reproduce the problem?
      1. Start stock camera app
      2. Take a photo
      3. Change exposure to +2 (anything besides 0)
      4. Take another photo
      5. Observe that the photos have the same exposure

      Other apps that attempt to set the exposure also do not work.

      According to http://code.google.com/p/cyanogenmod/issues/detail?id=6696 this issue also affects d2vzw.

      The attached logcat is for cm-10.0.0, but I can confirm the same problem in cm 10.1m1.

      1. CYAN-79 logcat.txt
        64 kB
        D Yong
      2. logcat.txt
        873 kB
        Benjamin Paul

        Activity

        stako Taylor Zimmermann added a comment - - edited

        Still mostly present in CM11 M6 on my d2lte build. When using Focal or ZOOM FX (camera apps), if I adjust the exposure slider very gently, the exposure will in fact change, but only for the first few notches. If I move the slider too far from the default center, the exposure stops working.

        dyong D Yong added a comment -

        Bump to CM11 M7 on d2lte

        dyong D Yong added a comment -

        Bump to CM11 M8 on d2lte

        antermoia Alexander S. Kunz added a comment -

        As if anyone's ever going to fix this...

        invisiblek Dan Pasanen added a comment -

        Yea...someone might look at it...some day...

        Enjoy!

        http://review.cyanogenmod.org/#/c/70383/
        http://review.cyanogenmod.org/#/c/70384/

        I'm running one final test build here, if all's well it'll be merged tonight.
        Looks like it won't be in the nightlies until tomorrow's build though (cm-11-20140814-NIGHTLY-d2lte.zip) you've been waiting all this time, what's one more day? xD


          People

          • Assignee:
            invisiblek Dan Pasanen
            Reporter:
            dyong D Yong
          • Votes:
            22 Vote for this issue
            Watchers:
            23 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: